Παρασκευή, 4 Απριλίου 2014

Κεφάλαιο 3

Κεφάλαιο 3 – Ερωτήσεις






1.             Να δώσετε τους ορισμούς για τις παρακάτω έννοιες:
a)       Πίνακας
b)       Διάσταση πίνακα




2.             Να δώσετε τους ορισμούς για τις παρακάτω έννοιες:
a)       Στοίβα
b)       Λίστα
c)       Ουρά



3.             Ποιοι είναι οι τρόποι ταξινόμησης στοιχείων μονοδιάστατου πίνακα; Περιγράψτε έναν. Ποια είναι τα κρίσιμα σημεία του ΑΛΓΟΡΙΘΜΟΥ: ΤΑΞΙΝΟΜΗΣΗ ΦΥΣΑΛΙΔΑ ;




4.             Ποιοι είναι οι τρόποι αναζήτησης στοιχείου σε μονοδιάστατο πίνακα ; Περιγράψτε έναν.
Ποια είναι η συνθήκη για την ΑΝΑΖΗΤΗΣΗ ΣΤΟΙΧΕΙΟΥ ΣΕ ΠΙΝΑΚΑ;
Πώς εξασφαλίζεται ότι  βρέθηκε ή δε βρέθηκε το στοιχείο που ψάχνουμε ;

 


5.             Τι εννοούμε με τον όρο αντιμετάθεση στοιχείων που βρίσκονται στην κ και στην κ+1 θέση ενός πίνακα Α; Με ποιες εντολές υλοποιείται;



6.            Ποια είναι τα δεδομένα; Από ποιες σκοπιές τα μελετά Η Πληροφορική Επιστήμη ;



7.             Τι είναι δομή δεδομένων;  Ποιες είναι οι λειτουργίες (πράξεις) που εκτελούμε επί αυτών ;

 

8.             Τι λέγεται στατική και τι δυναμική δομή.




9.             Έστω πίνακας Ν (Ν=100) στοιχείων. Περιγράψτε τη μέθοδο αναζήτησης στοιχείου KEY από την 10η θέση του πίνακα προς τη Ν-οστή. Η μέθοδος να βρίσκει και να εμφανίζει όλα τα κελιά του πίνακα που περιέχουν το ΚΕΥ.




10.         Δίδεται το τμήμα αλγορίθμου:

Ν=100
ΓΙΑ Ι ΑΠΟ 1 ΜΕΧΡΙ Ν
        ΔΙΑΒΑΣΕ Α[Ι]
ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
ΔΙΑΒΑΣΕ ΚΕΥ
Ι=5
ΟΣΟ Ι<Ν ΚΑΙ ΚΕΥ<>Α[Ι] ΕΠΑΝΑΛΑΒΕ
       Ι=Ι+1
ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ

Πότε σταματά ο αλγόριθμος;
Περιγράψτε τι κάνει!
Συμπληρώστε τον αλγόριθμο, ώστε να εμφανίζει τα πιθανά αποτελέσματα .



Δεν υπάρχουν σχόλια:

Δημοσίευση σχολίου